Switch to Linear ModeSwitch to Hybrid ModeSwitch to Threaded Mode
Printer Friendly View | Email this page | Register Now to start posting!
hongthai Registered User


Join Date: Aug 2011
Posts: 476
Trade rep: 16 (100%)
Infractions: 0/0 (0)
Lamtron anti vandal switch problem hongthai Apr 15th, 12, 07:12 PM #1

Hi am having a caselabs magnum M8 it came with lamptron anti vandal switch and am unable to turn on my system. I do liquid cooling and i did bleeding by only connect the green and black wires in mb psu cable just fine. Also the mb led is on but i cant use the power switch to turn on my system. So i suspect the powerswitch got some problem. Anyone know about this switch? Please help me. Thanks!


sg.png
lee-turbo
lee-turbo's Avatar
NOT Soon to be modder


Join Date: Mar 2010
Location: JB SG
Posts: 3,144
Trade rep: 14 (100%)
Infractions: 0/0 (0)
lee-turbo Apr 19th, 12, 08:40 AM #2
led need two wire to light up, power switch need two wire also
total connection is 4
plug in correctly ?
I should stop reading review from now onwards

Do i lost my passion for HW?

TBD+TBD +780 + M4 256G,2x1TB Seagate 7200.12+Seasonic P-1000
With Filco Ninja brown(PBT and red engraved mod) + Ducky wrist rest+ Razer Black edition Death Adder + Logitech G27(collecting dust) + 2713HM + TBD


Turbo Mod T-01
sg.png
New Thread | ↑↓ Similar Threads
Similar Threads Thread Starter Forum Replies Last Post
cyrilng Miscellaneous Garage Sales 3 Apr 22nd, 09
04:46 PM
cyrilng Case Modding 0 Feb 11th, 09
02:01 PM
someone_stupid Case Modding 10 Jun 8th, 08
06:37 PM
kengeroo Troubleshooting Zone/Technical Enquiries 0 Mar 17th, 08
08:56 PM
Mech Troubleshooting Zone/Technical Enquiries 1 Dec 15th, 06
11:03 AM
Thread Tools Display Modes
Linear Mode Linear Mode