Results 1 to 14 of 14
  1. #1
    Lackus Convictionus
    Join Date
    Dec 2005
    Posts
    5,388

    Razer Mamba Tracking Issues

    To all those guys who bought the Razer Mamba from VR Forum MO....
    And those who own a Razer Mamba.

    Just had it installed yesterday, used the latest driver 1.04 from Razer Support Site.

    I seem to have a few problems with the mouse and i am wondering if its a driver issue (very likely) or hardware issue.

    Here is the list of things i find strange

    1. Razer software: Cannot seem to lock in my preferences, esp the acceleration part. Everytime i shut down or restart the software seems to reset the acceleration part back to default. And its quite irritating for use.

    2. Tracking issue: Cursor seems to randomly skip around the screen (its not all the time, just once in a while)

    3. Dead Cursor: This happens when i leave the mouse untouched (watching movie, standby etc) for a while, when i move the mouse after a couple of mins of inactivity, it takes a while (5 secs) before the cursor on screen starts to move.

    4. Charging of mouse: When i leave it on the dock (be it 3 hrs or overnight) the batt meter does not seem to stop moving. Does this mean its still charging (even after 7 hrs) or is this just normal?



    Hope you all Mamba users can shed some light on these issues.
    Other than the above, everything seems to be ok.
    It may be that the gulfs will wash us down, it may be we shall touch the Happy Isles.
    We are not now that strength which in old days moved earth and heaven, that which we are, we are.
    Made weak by time and fate, but strong in will, to strive, to seek, to find, and not to yield.

  2. #2
    集中精神, 闭关修行 booest's Avatar
    Join Date
    Feb 2004
    Location
    Singapore
    Posts
    108,502
    damn~!
    my mamba still in box-_-"

    battery initial charge is 12~14 hours like phone i suppose
    Life is a Gift, Never take it forgranted
    | i5ooest:i5-4690S cooledby Kozuti | Maximus VII Impact mini-ITX | 2 x 8GB DDR3 | Extreme PRO 480Gb |
    | 1TB Veloci | MX800 | M12 II-620W | Jonsbo W1 |2707WFP (16:10) |

  3. #3
    Registered User
    Join Date
    Jun 2004
    Posts
    1,830
    Quote Originally Posted by booest View Post
    damn~!
    my mamba still in box-_-"

    battery initial charge is 12~14 hours like phone i suppose
    Pass to me i help u use it....

    I never charge mine batt at 1st, i charge it for an hr then start using. I charge it last night, mine the batt bar show soild green after it charge (that what i saw when i wake up today).

    The mamba auto power down when u idle, mine i just press the button or move the mouse it work.

    Btw i just patch it to 1.03 only, as when i download dont have 1.04.
    CPU 4960X
    MB Rampage IV Black Edition
    GPU GT 690x2
    RAM Corsair Dominator Platinium 4 x 4 GB 1866MHz CL9
    HDD Samsung Pro 840 256gb x 2 (Raid 0)
    PSU Seasonic X Series Platimun 1000W
    Case Caselabs SM8 Black

  4. #4
    garfield82 Sexmaster2k's Avatar
    Join Date
    Feb 2009
    Posts
    1,379
    Quote Originally Posted by Dihudaxia View Post
    To all those guys who bought the Razer Mamba from VR Forum MO....
    And those who own a Razer Mamba.

    Just had it installed yesterday, used the latest driver 1.04 from Razer Support Site.

    I seem to have a few problems with the mouse and i am wondering if its a driver issue (very likely) or hardware issue.

    Here is the list of things i find strange

    1. Razer software: Cannot seem to lock in my preferences, esp the acceleration part. Everytime i shut down or restart the software seems to reset the acceleration part back to default. And its quite irritating for use.

    2. Tracking issue: Cursor seems to randomly skip around the screen (its not all the time, just once in a while)

    3. Dead Cursor: This happens when i leave the mouse untouched (watching movie, standby etc) for a while, when i move the mouse after a couple of mins of inactivity, it takes a while (5 secs) before the cursor on screen starts to move.

    4. Charging of mouse: When i leave it on the dock (be it 3 hrs or overnight) the batt meter does not seem to stop moving. Does this mean its still charging (even after 7 hrs) or is this just normal?



    Hope you all Mamba users can shed some light on these issues.
    Other than the above, everything seems to be ok.
    Got my mamba from PCT, got all the problems above except for no.4
    You gotta dock ur mouse properly, it can easily 'hang' on the docking bay but doesnt mean it is in contact with the power point. Dock it properly and wait for the meter to move before you go and do your stuff, Im saying this is becos I had this b4, but I was waiting for the meter to move but it din, so I align it again to get it to charge properly
    [Mini-Review] PowerLogic Zen 1000 combo & Sensonic U3
    http://forums.hardwarezone.com.sg/sh....php?t=2986624
    SMK2 & GF82 S'pore FIRST LOOK at Swiftech H220
    http://forums.vr-zone.com/hardware-d...tech-h220.html
    Guide: mini-showdown : Corsair H70 vs XXXX GTX570
    http://forums.vr-zone.com/hardware-d...xx-gtx570.html

  5. #5
    Lackus Convictionus
    Join Date
    Dec 2005
    Posts
    5,388
    Hmmm, looks like i am not the only 1......
    Well monitor the batt charging issue once this current charge is depleted.

    But i am quite annoyed at the cursor jumping around when i am using it. Esp when i game.... Bleah!

    For a GAMING mouse, i find this quite unacceptable. Hopefully its a driver issue, not a hardware issue.
    It may be that the gulfs will wash us down, it may be we shall touch the Happy Isles.
    We are not now that strength which in old days moved earth and heaven, that which we are, we are.
    Made weak by time and fate, but strong in will, to strive, to seek, to find, and not to yield.

  6. #6
    Happy User cheesified's Avatar
    Join Date
    Nov 2008
    Location
    Hougang
    Posts
    3,555
    for all razer laser mouse, seems to have that kind of problem.

    copperhead>lachesis has this cursor jumping problem, i'm quite surprised that mamba has this bug after the few years too. guess razer didnt addressed the problem. heard that getting a good mouse pad solves this particular problem, but it doesnt solve for me.
    NZXT Tempest v1
    MSI p55a Fuzion | ci5-760 @ 2.8ghz, W/Hyper 212 & MX-2
    2x4GB Crucial Ballistix Tacticals DDR3-1600Mhz CL9
    MSI GTX660 Hawk | Samsung S24B350T
    SteelSeries 5Hv2/Altec Lansing 2.1
    Enermax Modu 82+ 625W Bronze
    Western Digital AALS 2x 640GB /EADS 1x 1TB
    SteelSeries Sensei W/ Destructor | G105
    Aerocool Modern-V
    4x Gelid UV Wing 120mm | 2x Xigmatech 140mm


  7. #7
    Super User
    Join Date
    Aug 2007
    Posts
    1,961
    Lachesis had the cursor jumping problem initially. However, if you upgrade the firmware the problem should go away. It did for me.

  8. #8
    Super Meanarator
    Join Date
    Sep 2004
    Location
    Upper Serangoon
    Posts
    15,788
    I used to have the jumping problem as well. My RMAed set fixed it.

  9. #9
    Lackus Convictionus
    Join Date
    Dec 2005
    Posts
    5,388
    Quote Originally Posted by cheesified View Post
    for all razer laser mouse, seems to have that kind of problem.

    copperhead>lachesis has this cursor jumping problem, i'm quite surprised that mamba has this bug after the few years too. guess razer didnt addressed the problem. heard that getting a good mouse pad solves this particular problem, but it doesnt solve for me.


    I am using Razer's own mousepad.
    Looks like its not a good one.

    Kidding.....




    Quote Originally Posted by sabe View Post
    I used to have the jumping problem as well. My RMAed set fixed it.
    You RMAed a Mamba already?
    Hassle free?
    Comtemplating to do the same if this issue does not go away by the next driver upgrade.
    It may be that the gulfs will wash us down, it may be we shall touch the Happy Isles.
    We are not now that strength which in old days moved earth and heaven, that which we are, we are.
    Made weak by time and fate, but strong in will, to strive, to seek, to find, and not to yield.

  10. #10
    Super Meanarator
    Join Date
    Sep 2004
    Location
    Upper Serangoon
    Posts
    15,788
    Nah I'm referring to the jumping problem on the Lachesis pointed out by Teemax above me.

  11. #11
    Registered User
    Join Date
    Jan 2008
    Posts
    1,208
    thats why i go for logitech.
    use razer deathadder before. great mouse but the software is buggy.

  12. #12
    Registered User
    Join Date
    Jan 2009
    Posts
    1,169
    2. Tracking issue: Cursor seems to randomly skip around the screen (its not all the time, just once in a while)

    Mouse jumping happen to all laser mouse as its too sensitive.especially on cloth based mouse, changing to a hard surface mouse pad help alot...based on personal experience of using Ikari laser mouse.

  13. #13
    Lackus Convictionus
    Join Date
    Dec 2005
    Posts
    5,388
    Quote Originally Posted by DangerousSean View Post
    2. Tracking issue: Cursor seems to randomly skip around the screen (its not all the time, just once in a while)

    Mouse jumping happen to all laser mouse as its too sensitive.especially on cloth based mouse, changing to a hard surface mouse pad help alot...based on personal experience of using Ikari laser mouse.

    Hmmm, i did not set to full max sensitivity, i am using 3,200dpi max.
    And on a hard surface mouse pad too.
    Hehehe

    Oh well.... I shall monitor the situation and see how it progresses.
    It may be that the gulfs will wash us down, it may be we shall touch the Happy Isles.
    We are not now that strength which in old days moved earth and heaven, that which we are, we are.
    Made weak by time and fate, but strong in will, to strive, to seek, to find, and not to yield.

  14. #14
    Lackus Convictionus
    Join Date
    Dec 2005
    Posts
    5,388
    5th June update.


    My Mamba went thru 2 charges over the last week and a half.

    Here is what i have found.

    Charge 1 using direct cable to mouse charging:
    Yellow batt bars at the side started charging, left it for 8 hrs, came back and its fully charged, yellow bars are at 3 points, and stopped moving


    Charge 2 using docking to wireless hub/charger:
    Made sure its secure and connect is correct, yellow batt bars at the side started charging, left it for 9 hrs, came back and the yellow bars are still moving up and down, meaning its not fully charged.


    Why is it when i use the cable directly it can do a full charge but not with the dock??? Software issue or hardware issue? Does this warrant an RMA?



    Side note: Mouse cursor jumping all over the place issue seems to have disappeared for the moment, very seldom happens if at all.

    The resume from sleep (long periods of inactivity) still persist. Irritating.

    No updates from Razer Support yet. Still waiting.
    It may be that the gulfs will wash us down, it may be we shall touch the Happy Isles.
    We are not now that strength which in old days moved earth and heaven, that which we are, we are.
    Made weak by time and fate, but strong in will, to strive, to seek, to find, and not to yield.

Similar Threads

  1. Razer Lycosa Mirror Special Edition™ and Razer Arctosa™
    By newzhunter in forum News around the web!
    Replies: 6
    Last Post: Oct 18th, 08, 01:41 PM
  2. Razer Lycosa Keyboard & Piranha Headset
    By newzhunter in forum News around the web!
    Replies: 1
    Last Post: Oct 5th, 07, 10:58 AM
  3. Get your Gigabyte 965P Mobo Bios Here!
    By orca in forum Hardware Depot
    Replies: 25
    Last Post: Apr 11th, 07, 09:12 AM
  4. Replies: 23
    Last Post: Dec 9th, 06, 12:24 PM